禁用WordPress 5.0的编辑器,换回传统编辑器

WordPress 5.0的Gutenberg(古腾堡)编辑器很是不适应,下面是禁用WordPress 5.0的编辑器,并换回传统编辑器得代码。

1、add_filter(‘use_block_editor_for_post’, ‘__return_false’);
将上面的代码添加到当前主题函数模板functions.php中,即可切换回之前的编辑器,不需要插件。

2、后台禁用block editor编辑器后,前端还是会加载相关的的样式文件,还需要加上一句:
remove_action( ‘wp_enqueue_scripts’, ‘wp_common_block_scripts_and_styles’ );
禁止前端加载样式文件。

也即下面的代码:

add_filter(‘use_block_editor_for_post’, ‘__return_false’);

remove_action( ‘wp_enqueue_scripts’, ‘wp_common_block_scripts_and_styles’ );

 

未经允许不得转载:LowVPS » 禁用WordPress 5.0的编辑器,换回传统编辑器

赞 (0)

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址